Username
Forgot password?
Welcome to our site!
Or Join with FTTF

This is a multi-browser test for tag auto-compete

0

871 views
I'm creating this post with some existing tags using Chrome .. then I will edit the tags in other browsers..

the first thing I noticed is that my normal tagging approach doesn't work. . I usually type in a letter or two of a well known tag .. and then select the tag I want from autocomplete dropdown with mouse.. but that got me this:



will try a different approach ..

this time I tried to arrow down with the arrow keys.. to select something in dropdown... that works much better.. in fact I may change to that way of doing it.. . with arrow keys, not mouse.




  • did some retag with Firefox.. works as with Chrome.. auto-complete select works well with keypad
  • this is interesting.. selecting tags in dropdown in IE works great with mouse, or keypad.. not my fav browser... but there you go.. that's how it should work IMO
  • Safari works very much like FF and Chrome.. keypad is good for chosing dropdown tags.. but not mouse.. which adds and extra character like this





 
Edited June 8, 2011 10:21 pm CDT
safari test
asked June 8, 2011 at 10:05 PM

 US

3 Answers

0
 
Here's what the page resources look like on the question page with tag dialog in play:



flag
answered June 9, 2011 at 4:33 PM
OK, looks good, you are getting the right js file but really not sure why you still having the old bug that I don't see anymore. That's why it's so hard to test websites in real life, because sometimes different people report different results on the same page using the same browser.
flag
Jun 9 '11 at 16:51
roger that.. I have a LAN for multi-browser/OS/platform testing and there are sill plenty of strange quirks that sneak through to production.. even if I clear cache 500 times / day..
flag
Jun 9 '11 at 17:45
0
 
I just tried it after clearing all cache and reloading... still does it.. but please note that I'm using the retag in these tests in addition to the initial tag in ask page. seeing behavior in both.. PC, not Mac... I'll keep trying to isolate it..
flag
Edited June 9, 2011 9:16 am CDT
.
answered June 9, 2011 at 9:07 AM
1
OK, I'll check this too. Not sure why it works for me. I only tried the "new question" form so far
flag
Jun 9 '11 at 9:20
This is very strange. When you view page source, so you see path to http://support.lampcms.com/js/min/qa_06082011.js or is it path to /js/qa.js ? I wonder if for some reason you are getting the non-minified version of js file?
flag
Jun 9 '11 at 15:53
0
 
This is strange. What you describing is a buggy behaviour of the orifinal widget.
You can see it on the original widget demo page

http://rgrove.github.com/node-tokeninput/examples/example-autocomplete.html

(try apple, banana, cherry)

But since I applied a fix the bug is gone, you can select the autosuggested tag with a mouse (or with keyboard) now. I mean it works for me on this site using Chrome on Windows.

I am not sure about other browsers. Maybe it's different on Mac?

Have you reloaded the "Ask" page while holding down the shift key to update browser cache? I mean, is it possible that you were still using the old version of javascript file?

flag
answered June 9, 2011 at 7:58 AM

Your answer

Join with account you already have

FTTF

Preview

Alert